RIME support for Fcitx

RIME(中州韻輸入法引擎) is mainly a Traditional Chinese input method engine.

project: https://code.google.com/p/rimeime

Build From Source:

special notice of RIME dependency:

RIME split its devlopment source into a few sections, here we need librime.

In librime source, there are two directory, brise and librime.

According to your distribution, you might need brise+librime package(openSUSE) or only librime which includes brise at /usr/share/brise.

If your distribution doesn't have one you need to download librime and put brise directory into /usr/share/brise.

If you're a distribution packager, ask maintainer of librime to add brise sub-package.

special notice of Boost dependency:

Boost is a RIME dependency, so without boost >= 1.46.1, you will not ble to install librime-devel.

Generally it means, distros that are a little old like openSUSE 11.4 or Ubuntu 10.10 might not be possible to build or install.

Dependency

*cmake

*gcc-c++

*fcitx-devel with all three skins

some distro like openSUSE split a fcitx-skin-classic and a fcitx-skin-dark, so you need them.

*librime-devel

*brise

*hicolor-icon-theme

optional, for directory ownership.

openSUSE:

sudo zypper ar -f http://download.opensuse.org/repositories/M17N/openSUSE_12.2/ M17N

sudo zypper in cmake gcc-c++ fcitx-devel fcitx-skin-classic fcitx-skin-dark librime-devel brise hicolor-icon-theme

Install from Distribution

openSUSE

sudo zypper ar -f http://download.opensuse.org/repositories/M17N/openSUSE_12.2/ M17N

sudo zypper in fcitx-rime


RIME支持Fcitx

RIME(中州韵输入法引擎)主要是一种繁体中文输入法引擎。

项目: https://code.google.com/p/rimeime

从源代码:

RIME依赖关系的特别通知:

RIME将其开发源分为几个部分,这里我们需要librime。

在librime源中,有两个目录,brise和librime。

根据您的发行版,您可能需要使用brise + librime软件包(openSUSE)或只包含/ usr / share / brise中的brise的librime。

如果您的发行版没有您需要下载librime并将brise目录放入/ usr / share / brise。

如果你是一个分发包装程序,请问librater的维护者添加brise子包。

Boost依赖的特别通知:

Boost是一个RIME依赖,所以没有boost> gt = = 1.46.1,你不会安装librime-devel。

一般来说,这意味着,像OpenSUSE 11.4或Ubuntu 10.10这样一些旧版本的发行版可能无法建立或安装。

依赖关系

* cmake

* gcc-c ++

* fcitx-devel与所有三个皮肤

一些发行版,如openSUSE,将fcitx-skin-classic和fcitx-skin-dark分开,因此您需要它们。

* librime-devel

* brise

* hicolor-icon-theme

可选,用于目录所有权。

openSUSE:

sudo zypper ar -f http://download.opensuse.org/repositories/M17N/openSUSE_12.2/ M17N

sudo zypper in cmake gcc-c++ fcitx-devel fcitx-skin-classic fcitx-skin-dark librime-devel brise hicolor-icon-theme

从分发安装

openSUSE

sudo zypper ar -f http://download.opensuse.org/repositories/M17N/openSUSE_12.2/ M17N

sudo zypper in fcitx-rime




相关问题推荐