Ezbl - Emacs interface for Uzbl (uzbl.org)

This package creates an Emacs interface for Uzbl, allowing you to control Uzbl from within Emacs.

Requirements

  • Uzbl (http://www.uzbl.org) version 2009.11.30 or greater. Older version will not work.
  • A patched version of Emacs (http://github.com/dhax/emacs/tree/xembed) which supports embedding Xwidgets and the SOCK_SEQPACKET socket type. These patches are currently (as of 2009-12-20) not available in the main Emacs repository, nor in any released version.

Installation

Move the file “ezbl.el” to somewhere in your load-path. Add “(require ‘ezbl)” to your .emacs file, and run “ezbl-open” to launch a Uzbl instance.

Development

As of version 0.2, the “master” branch on http://github.com/dhax/ezbl should be considered stable. Updates to that branch should not break existing functionality, and experimental features will be developed in other branches and merged to “master” once they are acceptably stable.

Related files

All of the documentation files (including this one) are in Emacs org-mode format and are best viewed with a recent version of org-mode. Being plain text, however, they are still viewable in any text editor.

Some files of interest might be:

  • NEWS.org: History of changes in each Ezbl version.
  • COPYING: The license of Ezbl (GPLv3+).
  • TODO.org: Known bugs and desired features.


Ezbl - Uzbl(uzbl.org)的Emacs界面

此包为Uzbl创建了一个Emacs界面,允许您控制Uzbl   来自Emacs。

Requirements

      
  • Uzbl( http://www.uzbl.org )版本2009.11.30或更高版本。旧版本会     不工作。
  •   
  • 修补版的Emacs( http://github.com/dhax/emacs/tree/xembed ) 哪一个     支持嵌入Xwidgets和SOCK_SEQPACKET套接字类型。这些     目前(截至2009-12-20)的补丁在主Emacs中不可用     存储库,也不在任何发布的版本。

Installation

将文件ezbl.el移动到加载路径中的某个位置。添加(require’ezbl)   到.emacs文件,并运行ezbl-open启动Uzbl实例。

Development

从版本0.2开始, http://github.com/dhax/ezbl 上的主分支应该   被认为是稳定的。该分支的更新不应该破坏现有的   功能和实验功能将在其他分支机构开发   并且被合并为主人,一旦他们是可以接受的稳定。

Related files

所有文档文件(包括此文件)均在Emacs组织模式下   格式,最好使用最新版本的组织模式查看。平原   但是,它们仍然可以在任何文本编辑器中查看。

某些感兴趣的文件可能是:

      
  • NEWS.org:每个Ezbl版本的更改历史。
  •   
  • 复制:Ezbl(GPLv3 +)的许可。
  •   
  • TODO.org:已知错误和所需的功能。




相关问题推荐