问题

我安装了DotNetOpenAuth SDK-3.4.5.10201.vsix,我无法得到它的工作. 它工作在本地(当我作为localhost运行),但是当我尝试发布它是不工作.

我收到的IIS错误消息是

Error Summary
HTTP Error 500.22 - Internal Server Error
An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

AND

Module       ConfigurationValidationModule  
Notification BeginRequest  
Handler      StaticFile  
Error Code   0x80070032  

那么有一些建议如何解决问题:

您可以尝试的内容:

  • Migrate the configuration to the system.webServer/modules section. You can do so manually or by using AppCmd from the command line - for example, %SystemRoot%\system32\inetsrv\appcmd migrate config "Default Web Site/". Using AppCmd to migrate your application will enable it to work in Integrated mode, and continue to work in Classic mode and on previous versions of IIS.

  • If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.

  • Alternatively, switch the application to a Classic mode application pool - for example, %SystemRoot%\system32\inetsrv\appcmd set app "Default Web Site/" /applicationPool:"Classic .NET AppPool". Only do this if you are unable to migrate your application.
    (Set "Default Web Site" and "Classic .NET AppPool" to your application path and application pool name)

但问题是,我没有访问的ISS服务器,因为我不是它的所有者.有什么办法解决这个问题吗?



解决方法

2 nd 选项是您想要的选项.

web.config 中,确保这些键存在:

<configuration>
    <system.webServer>
        <validation validateIntegratedModeConfiguration="false"/>
    </system.webServer>
</configuration>



相关问题推荐